KUSANAGI Module Update

KUSANAGI Module Update

KUSANAGI modules have been updated.
The updated modules are as follows:

php 8.0.20-2.el7

The module update can be applied with the following command:

# yum update --enablrepo=remi,remi-php56

If you are using php8, please reboot with the following command:

# kusanagi php8

KUSANAGI Module Update

KUSANAGI Module Update

KUSANAGI modules have been updated.
The updated modules are as follows:

php 7.4.30-2

The module update can be applied with the following command:

# yum update --enablrepo=remi,remi-php56

If you are using php7, please reboot with the following command:

# kusanagi php7

KUSANAGI Module Update

KUSANAGI Module Update

KUSANAGI modules have been updated.
The updated modules are as follows:

nginx 1.21.6-2

The module update can be applied with the following command:

# yum update --enablerepo=remi,remi-php56

If you are using nginx, please reboot with the following command:

# kusanagi nginx

KUSANAGI Module Update

KUSANAGI Module Update

KUSANAGI modules have been updated.
The updated modules are as follows:

openssl 3.0.4-1 This update includes support for vulnerability(CVE-2022-1292,CVE-2022-1292,CVE-2022-2068).

The module update can be applied with the following command:

# yum update

After updating, restart KUSANAGI with the following command.

# kusanagi restart

KUSANAGI update 8.7.2-1

KUSANAGI update 8.7.2-1

KUSANAGI update has been released.

Failure in registering certification transparency (CT) with kusanagi ssl command has been fixed.

You can update to the latest version by execute command showing below:

 # yum update -y

KUSANAGI Module Update

KUSANAGI Module Update

KUSANAGI modules have been updated.
The updated modules are as follows:

php 8.0.20-1.el7 This update includes support for vulnerability(CVE-2022-31626,CVE-2022-31625).

The module update can be applied with the following command:

# yum update --enablrepo=remi

If you are using php8, please reboot with the following command:

# kusanagi php8

KUSANAGI Module Update

KUSANAGI Module Update

KUSANAGI modules have been updated.
The updated modules are as follows:

httpd 2.4.54-1 This update includes support for vulnerability(CVE-2022-31813,CVE-2022-30556,CVE-2022-30522,CVE-2022-29404,CVE-2022-28615,CVE-2022-28614,CVE-2022-28330,CVE-2022-26377).

The module update can be applied with the following command:

# yum update

If you are using httpd, please reboot with the following command:

# kusanagi httpd

KUSANAGI Module Update

KUSANAGI Module Update

KUSANAGI modules have been updated.
The updated modules are as follows:

php 7.4.30-1 This update includes support for vulnerability(CVE-2022-31626,CVE-2022-31625).

The module update can be applied with the following command:

# yum update --enablrepo=remi

If you are using php7, please reboot with the following command:

# kusanagi php7

KUSANAGI update 8.7.1-1

KUSANAGI update 8.7.1-1

KUSANAGI update has been released.

Failure in updating SSL certificate with kusanagi ssl command has been fixed.

You can update to the latest version by execute command showing below:

 # yum update -y

KUSANAGI update 8.7.0-1

KUSANAGI update 8.7.0-1

KUSANAGI update has been released.

Default PHP initialized with kusanagi init command has been changed to PHP 8.0.
If you want to use PHP 7.4, you need to use kusanagi init command with --php7 option.
After the initalization, you can also switch to PHP 7.4 by kusanagi php7 command, or PHP 8.0 by kusanagi php8 command.

You will need WordPress 5.6 or higher to use PHP 8.0.
Also check whether your plugins and themes support PHP 8.0.

You can update to the latest version by execute command showing below:

 # yum update -y